Announcement

Collapse
No announcement yet.

dome won't retain pressure/does this happen over time?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • dome won't retain pressure/does this happen over time?


    Hi Marlon,


    I have been having trouble with retaining pressure inside the dome of the LG hanger. I have a very new sleeve (under 50 hangs, I practice rubber maintenance, and always hang on clean skin) so that is not the issue. My hand pump is working correctly because I can put my thumb over the male coupler while pumping and the pressure will stay at a certain level; there is no leak there. I think something is happening in the female coupler fitting. I tried unscrewing the female coupler and wrapping it with teflon tape. This did not fix the problem for losing pressure when pumping.

    To be clear, this is not a gradual loss of pressure, but rather the gauge will not even pump to higher numbers temporarily when the hand pump is attached to the dome.

    Please advise what you would recommend. The pressure is integral to my routine, especially on my heavy hang sessions where I hang 15 lbs.

    Thanks.

  • #2
    Originally posted by MJN```13 View Post
    Hi Marlon,


    I have been having trouble with retaining pressure inside the dome of the LG hanger. I have a very new sleeve (under 50 hangs, I practice rubber maintenance, and always hang on clean skin) so that is not the issue. My hand pump is working correctly because I can put my thumb over the male coupler while pumping and the pressure will stay at a certain level; there is no leak there. I think something is happening in the female coupler fitting. I tried unscrewing the female coupler and wrapping it with teflon tape. This did not fix the problem for losing pressure when pumping.

    To be clear, this is not a gradual loss of pressure, but rather the gauge will not even pump to higher numbers temporarily when the hand pump is attached to the dome.

    Please advise what you would recommend. The pressure is integral to my routine, especially on my heavy hang sessions where I hang 15 lbs.

    Thanks.
    To test to see if your chamber is leaking / or better put to see if you have a defective female fitting do the following:

    Remove the rubber from your chamber. Shave a small section of skin on your belly or thigh. While the hand pump is attached to the chamber, hold the mouth of the chamber firmly against the shaved portion of your skin. Draw out vacuum.... if the female fitting is leaking then the needle on the hand pump will fall to zero immediately.

    Comment


    • #3
      I just tested this on my stomach. I can get suction when I pump to 5 Hgs, but it falls to 0 within 3 seconds. Do I need a new female fitting?

      Comment


      • #4
        Originally posted by MJN```13 View Post
        I just tested this on my stomach. I can get suction when I pump to 5 Hgs, but it falls to 0 within 3 seconds. Do I need a new female fitting?
        You have two options.....
        If you believe the female fitting is the problem, you can purchase a new one from our website. It will come wrapped with new Teflon Tape and a new rubber o'ring, and you can reinstall it yourself.
        Or you can ship your chamber back to us, and we would be happy to trouble shoot for you for a minimal charge of $25.00 and if we find if it is the fitting there will be an additional charge for a new fitting and return shipping.

        I personally believe it's probably not the fitting, but a compromised seal between the sleeve and your penis skin. The heavier weights you're using does tend to make your penis thinner during the hang and that alone can compromise the seal between skin and rubber, and cause a slow leak. You might want to consider using a smaller sleeve.

        Comment


        • #5
          I'll be purchasing the female fitting. I'm using a very new sleeve and haven't had issues like this before (have about 300 hours of hang time with the LG). I'm not losing suction during the hang. The pump is unable to even briefly read10 Hg or higher before a hang.

          Comment


          • #6
            I just received the new female fitting and installed it. Unfortunately, I'm still having the same issues. I then put on a brand new sleeve which still did not solve the problem (I use the .875" sleeves). I can't go to a smaller size. Also my mid-shaft girth is 5" so I'm not ultra-skinny to begin with...

            The only other thing I can think of is that my pump is defective. However, when I place my thumb over the end of the pump (against the male coupler) I can reach high pressures that will stay on the gauge (not falling back immediately after pumping). Is there maybe something happening with the air as it leaves the male coupler into the female coupler. Maybe there's something wrong with the male fitting?

            This is extremely frustrating and has put a halt to my training. What do you recommend now?

            Comment


            • #7
              Originally posted by MJN```13 View Post
              I just received the new female fitting and installed it. Unfortunately, I'm still having the same issues. I then put on a brand new sleeve which still did not solve the problem (I use the .875" sleeves). I can't go to a smaller size. Also my mid-shaft girth is 5" so I'm not ultra-skinny to begin with...

              The only other thing I can think of is that my pump is defective. However, when I place my thumb over the end of the pump (against the male coupler) I can reach high pressures that will stay on the gauge (not falling back immediately after pumping). Is there maybe something happening with the air as it leaves the male coupler into the female coupler. Maybe there's something wrong with the male fitting?

              This is extremely frustrating and has put a halt to my training. What do you recommend now?
              Nothing is wrong with the chamber, the female or male fitting, and if your hand pump test has proven that it's not the hand pump then the process of elimination results in only one conclusion..... you are losing vacuum or leaking via the skin / sleeve connection.

              Here are some tips to help cure the problem...
              Before you attach weight, prime your chamber 5-6 times. To do this just install your chamber, plug in the hand pump, draw out 10-15 Hg's of vacuum pressure, hold for 2-3 seconds and then release the pressure with the hand pump trigger. Then repeat this 5 more times. This will help draw blood into your penis and allow glans expansion to "pack" the chamber. On your last prime go to your desired amount of vacuum pressure and disconnect the hand pump and hang. It also is of great benefit that you make sure you warm up sufficiently prior to your hang session. I suggest you get approximately 50% erect.

              Now if any time during your hang session you begin to feel a "slip" and the weight is pulling the chamber off your penis, then stop your hang session and reload. Just check your glans protection wrap and begin the priming process all over again. You should be very proficient at installing your chamber at this point and it shouldn't take any longer than a minute or two to reload.

              Remember your goal is to reach fatigue, and if you are aiming to do a full one hour session it really doesn't matter if you have to reload two or three times during the hour.

              I'm pretty confident that during your hang session your penis is getting thinner during the stretch and this is compromising the seal between the penis skin and silicon sleeve which is causing you to leak vacuum and erroneously believe the problem lies within the chamber or fittings.

              Comment


              • #8
                Before I attach the weight, the dome will not retain ANY pressure at any moment so it is impossible for me to prime the chamber. I can't draw out 10-15 HG's of pressure for 2-3 seconds if I can't achieve any pressure for any amount of time. Should I send a video to elucidate this problem? I feel I have explained my issue multiple times...

                I am not new to hanging so I am accustomed to warming up and priming the chamber to retain friction (approximately 300 hours of hanging total). Now all of a sudden, my device won't retain any pressure for any length of time BEFORE hanging weight.

                Comment


                • #9
                  Email us and my wife will send you a "trouble shooting" form to fill out so we can help you identify your problem. We may request you send a video so that I can properly diagnose your issue.

                  Comment


                  • #10
                    I have the solution for you, I was having the same problem and ended up replacing several things that I didn’t need to. I have a feeling all you need to do is pull out the male tip of the pump hose, Wrap it with Teflon tape a few times and insert it back into the female coupler on top of the dome, it makes a dramatic difference

                    Comment


                    • #11
                      I have the solution for you, I was having the same problem and ended up replacing several things that I didn’t need to. I have a feeling all you need to do is pull out the male tip of the pump hose, Wrap it with Teflon tape a few times and insert it back into the female coupler on top of the dome, it makes a dramatic difference

                      Comment


                      • #12
                        Originally posted by MJN```13 View Post
                        Before I attach the weight, the dome will not retain ANY pressure at any moment so it is impossible for me to prime the chamber. I can't draw out 10-15 HG's of pressure for 2-3 seconds if I can't achieve any pressure for any amount of time. Should I send a video to elucidate this problem? I feel I have explained my issue multiple times...

                        I am not new to hanging so I am accustomed to warming up and priming the chamber to retain friction (approximately 300 hours of hanging total). Now all of a sudden, my device won't retain any pressure for any length of time BEFORE hanging weight.
                        You either have a problem with a worn sleeve that is not making good contact with your penis skin or it could be the hose connection on the hand pump. After 300 hours of use the hose that slides onto the end of the hand pump nipple can get loosened up. Pull the hose off the hand pump and clip the end off about 1/2" with a pair of scissors and then plug it back onto the hand pump nipple.

                        Comment

                        Working...
                        X